lunes, 6 de julio de 2009

unir dos vectores



aca se ingresa el contenido de dos vectores de 4 posiciones en un vector de 8 posiciones

5 comentarios:

  1. // 8. Hacer un algoritmo que lea dos vectores de N y M posiciones. Crear un vector con la unión de ambos
    // vectores e imprimirlos. Ejemplo
    // Vector A
    // 4 16 25 7 9
    // Vector B
    // 17 178 29 38 46 52
    // Vector Unión
    // 4 16 25 7 9 17 178 29 38 46 52
    Proceso sin_titulo
    Dimension vec1[200]
    Dimension vec2[200]
    Dimension vunion[200]
    i<-1
    Escribir "Ingrese (Genere) la cantidad de datos primer vector:";
    Leer N;
    Para i<-1 Hasta N Hacer
    numazar<-azar(10)
    vec1[i]<-numazar
    Escribir "Ingrese el dato ",i,": ", numazar;
    FinPara

    Escribir ""
    Escribir "Ingrese (Genere) la cantidad de datos segundo vector:";
    Leer M;

    Para i<-1 Hasta M Hacer
    numazar<-azar(10)
    Escribir "Ingrese el dato ",i,": ", numazar;
    vec2[i]<-numazar
    FinPara

    Para i<-1 Hasta N Hacer
    vunion[i]<-vec1[i]
    FinPara
    nvunion<-N
    Para k<-1 Hasta M Hacer
    i<-1
    Mientras (i<=N) Hacer // & (vec2[k] <> vec1[i-1]) //Agregue lo anterior si quiere que solo los elementos no repetidos estén en el nuevo vector
    i<-i+1
    FinMientras
    si i>N Entonces
    nvunion<-nvunion+1
    vunion[nvunion]<-vec2[k]
    FinSi
    FinPara
    Para i<-1 Hasta nvunion Hacer
    Escribir vunion[i]
    FinPara

    FinProceso

    ResponderEliminar
  2. hola como estas, te hago una consulta, cuando decis agrege lo anterior para que no me una los elementos repetidos a que parte del codigo te referis? esta : (vec2[k] <> vec1[i-1])?
    gracias saludos

    ResponderEliminar
  3. en el caso que los vectores no tengan una dimensión fija?

    ResponderEliminar
  4. amigo la misma pregunta cuando decis agrege lo anterior para que no me una los elementos repetidos a que parte del codigo te referis? esta : (vec2[k] <> vec1[i-1])?
    gracias saludos

    ResponderEliminar
  5. necesito este mismo ejercicio pero en visual basic.net

    ResponderEliminar